Back to overview
Degraded performance for output feeds
Oct 22 at 09:37am CEST
Affected services
PriceShape App
Resolved
Oct 22 at 09:37am CEST
Some workers could not start. No data has been lost or compromized
Affected services
Resolved
Oct 22 at 09:37am CEST
Some workers could not start. No data has been lost or compromized
Affected services